Back
Maintenance

Mail server migration

Completed 16 Feb at 02:00am GMT.

Mail
Updated

All services fully migrated.

Posted 16 Feb at 02:05am GMT.
Completed

Maintenance completed

Posted 16 Feb at 02:00am GMT.
Updated

Services migrated to new server, updating DNS records now.

Posted 15 Feb at 11:51pm GMT.
Started

-

Posted 15 Feb at 10:38pm GMT.