fancy.org.uk
Status
Back
Maintenance
GitLab 15.11.5
Completed 20 May at 05:23pm BST.
Affected services
GitLab
Completed
Update completed.
Posted 20 May at 05:23pm BST.
Started
Updating GitLab to 15.11.5.
Posted 20 May at 01:30pm BST.